From Dev to Production-Don’t Forget Your Themes!

We finally pushed our new intranet from development to production the other day. As I was checking the pages I noticed my theme was not showing up in the Themes list. Doh. Anything in the 12 hive that you added does not push when you go from dev to production. You have to manually move copies to all production servers. In my case, our farm has five production servers, and I have a custom theme, so thats three things I need to copy over to each server:
1: spthemes.xml
2: thumbnail image for theme preview
3: custom theme folder

Beyond that oversight, everything pulled over fine, all of my relative links work, pages are there, masterpage and page layouts pulled, all is good. ;0

Advertisements

2 thoughts on “From Dev to Production-Don’t Forget Your Themes!

    • Honestly, my server admin handled all the file moving stuff. There are features within central admin that allow you to package up the whole site collection and move it to the production servers-that’s a topic a SharePoint admin probably has covered way better than me 😉

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s